Downloads/Dev

From Essentials

Jump to: navigation, search

Essentials is currently in the process of dual development, with the main development forked away from the main branch of Essentials. The team is concentrating on making a major rewrite of the core Essentials packages, to increase performance, usability and reduce memory footprint.

This is the second undertaking of such, in the last 6 months, and you will find the latest stable of Essentials 2 to be nowhere near as bloated as the earlier versions, largely helped by lazy loading, and the way Essentials will now give priority to other plugins for virtually all commands.

img.png

Essentials 2.x

Recommended Versions

Essentials 2.9.3 - Minecraft  1.3  - CraftBukkit 2289+
Essentials 2.9.2 - Minecraft  1.2  - CraftBukkit 2122+
Essentials 2.8 - Minecraft  1.1  - CraftBukkit 1821-1988
Essentials 2.7 - Minecraft  1.0  - CraftBukkit 1597-1712
Essentials 2.6 - Minecraft b1.8 - CraftBukkit 1185-1337
Essentials 2.5 - Minecraft b1.7 - CraftBukkit 1000-1060

Stable Builds

Use this if you are using Minecraft 1.3

You can find download links to the latest stable builds and build history on our TeamCity.

Download.png TeamCity/CI Download
Download.png Dev.Bukkit.org Download
Download.png GitHub Download

Pre-Release Builds

You can find download links to the latest pre-release builds and build history on our TeamCity.

Download.png TeamCity/CI Download
Download.png Dev.Bukkit.org Download

Dev Builds

Use this if you are testing only

Warning: Often our development builds do a one way upgrade of user files and config settings, so make sure to take a backup of your Essentials folder, in case you need to downgrade.

Keep in mind these are bleeding edge builds which may not be ready for general consumption.

You can find our latest development builds of Essentials on our TeamCity.

Download.png TeamCity/CI Download

Essentials 3.x

The main focus of development at the moment is Essentials 3.x, this development branch should for the time being considered unstable and not fit for use. For the most part of the development process to this point, the configuration files and user files have not been compatible, and at the time of writing no upgrade script is available. Therefore people trying these branches need to be using a fresh install of Essentials, including deleting user data.

At the current time, Essentials 3.x should only be used for development purposes, and not on a live server.

Dev Builds

Essentials3.x builds are not currently available. You probably weren't actually looking for these anyway.

Support

Remember, the point of releasing these dev builds, is so that we can help hammer our any bugs before release. Our primary support medium for dev builds on IRC in our help channel, but you can also post bugs on the ticket tracker. The information on this wiki will generally reflect that of the main Essentials release, and not the dev builds, so you may find some information missing, check the change log if you have issues.

Support us

Essentials is an open source Bukkit plugin, we develop this in our free time, and time is precious. Please consider a donation to help make our time spent on the plugin worth the investment.